Page 19 of 19

Re: Computerus

Posted: Tue Nov 14, 2017 12:52 pm
by Mongrel
Yeah I had to roll it back for that very reason (NoScript being removed from my hotbar).

Re: Computerus

Posted: Tue Nov 14, 2017 2:13 pm
by Thad
Yeah, the NoScript site still says the new version will be ready by the time 57 comes out, but nope!

Mobile version seems OK.

Desktop version locks up every single time I try to open the menu. Seriously. (Win7, at work.)

Re: Computerus

Posted: Tue Nov 14, 2017 2:19 pm
by Thad
And when I try to autoscroll. Super.

Going to try rebooting. If that doesn't fix, I guess it's back to the ESR version. (That's v52. You probably don't want to stick with 56, because it won't be getting any more security updates.)

Re: Computerus

Posted: Tue Nov 14, 2017 2:28 pm
by Brentai
Ha haaa I was so very prepared for this.

Re: Computerus

Posted: Tue Nov 14, 2017 3:12 pm
by Thad
Back to ESR for now. Won't plan on updating on my desktop or laptop at home (because I use NoScript on both). Might try on the HTPC.

Not seeing anyone else reporting my issue yet. I'll keep an eye out; it's still a brand new release.

Tried rebooting, tried uninstalling and reinstalling, tried deleting my profile (backed up first, of course). Issue persisted until I rolled back.

Re: Computerus

Posted: Tue Nov 14, 2017 4:07 pm
by Mongrel
I had to turn off the update notification function because it was badgering me to update every time I opened a new tab, plus some extra random times on top of that.


Re: Computerus

Posted: Tue Nov 14, 2017 4:22 pm
by Thad
Again, you might want to install the ESR. It'll continue to get security updates but won't prompt you to upgrade to a non-ESR version.

The differences between v52 and 56 are mostly superficial. In the old days, they would have been minor version bumps; Chrome kind of fucked up browser versioning for everybody.

Re: Computerus

Posted: Fri Nov 17, 2017 1:19 pm
by Thad
There's also Basilisk, a fork of Firefox 56.

Re: Computerus

Posted: Thu Nov 30, 2017 4:11 pm
by beatbandito
Firefox Quantum NoScript is out.

You should all get it now because my sister was hired by Mozilla for Quantum user retention and now that its released she seems to spend all day hooked up to a computer that shocks her whenever someone stops using current release.

I mean not that I do because Firefox's thing seems to follow the Bethesda method for development, and I'm not one to wait for mods to make the browser enjoyable, but you should.

Re: Computerus

Posted: Thu Nov 30, 2017 7:19 pm
by Brentai
If it helps, the primary reason I don't use Firefox as my main browser currently is that it doesn't handle opening images with bad MIME types gracefully.

Re: Computerus

Posted: Fri Mar 30, 2018 3:51 am
by Mongrel
So FF Quantum had enough options of its own that I was finally able to upgrade without worrying about too many busted UI add-ons (and I found replacements for all my outdated utility add-ons, so that worked out too). Plus most things not included by default as a customizable UI option can be altered or added using the chrome.css file, which just requires you to search around a bit for the right piece of code. So far so good.

Only there's one small problem - they removed the fucking STOP LOADING BUTTON!? (It technically exists the spot where refresh button is while the refresh animation plays... but only if you let the page load in the first place!).

Been searching for a bit and I keep finding advice from about two months ago that says "restore defaults" and then re-customize. Only I guess that doesn't work for the latest builds? Anyone have any ideas how I can fix this? I've found nothing about re-adding it via the chrome.css file either.

The fucking stop loading button... are you fucking kidding me? Seriously?

Re: Computerus

Posted: Fri Mar 30, 2018 6:51 pm
by Mazian
Looks like my Firefox stop loading button is right where it always was.


Re: Computerus

Posted: Fri Mar 30, 2018 7:14 pm
by mharr
Not sure if this is exactly the right thread, but it does seem to contain the right general expertise:

Does anyone have successful experience using virtualisation to sandbox not-quite-trusted games off into their own private OS environments? There's a growing list of apparently well meaning anti-cheat tools that are basically rootkits, and I'm wondering if there's a cheaper, more elegant way to deal with that than just buying a whole separate gaming rig for those titles?

Re: Computerus

Posted: Wed Apr 04, 2018 2:18 pm
by Mongrel
So a small FF Quantum issue.

Zoom is fucked on some forums and websites. For example, I might set it such the post text is same as it used to be, so that posts themselves are readable at least, but everything else is buggered as a result and may be oversized or undersized as a result. For example, the pages showing the subforums, or the subforum page showing topic lists on Bronto are now slightly oversized. On another forum those pages are undersized and all the icons are blurry no matter what zoom I have it set to.

Been googling for a while but I can't seem to find anything related to this. Is there a setting I can twiddle with on GG or FF which might fix this?

Is it because my screen is 16:10 and not 16:9? I could see that maybe being the issue.

Re: Computerus

Posted: Sun May 06, 2018 7:18 pm
by atog
Weird problem with mouse behaviour that I've posted elsewhere, and gotten the usual "download more rams, buy a new mouse, install windows 10, eat shit" responses.

About a year ago I started noticing I would have double-clicks AND nonresponsive clicks with the left mouse button. It's an old USB laser mouse, standard 2-buttons-and-a-scrollwheel, always been reliable up to this point. It started out as an occasional thing, then would wind up so bad I could not click without either having to mash and hold the left mouse button, OR risk double-clicking and resizing windows, double-opening tabs, etc.

I unplugged the mouse and took it apart, gave it a thorough and careful cleaning, made sure all the soldering jobs were intact and wires were in place, buttons and wheels cleared of cat hair and condensed sweat and grime, etc. Everything squeaky clean and electronically sound. Reassemble, reinstall, check drivers, etc.

No improvement. None at all.

It would mysteriously and suddenly disappear on its own.

And then, anywhere from 3 days to 3 months later, it would reoccur. Sometimes on the left mouse button, sometimes (more rarely) on the right. check windows updates, check drivers, adjust sensitivity settings, unplug mouse, ream it out, check contacts and soldering, reassemble, plug in, no improvement, then a few days to a few weeks later, instantly return to normal.

It doesn't seem to be linked to any application. Windows, Photoshop, Blender, Steam games, Minecraft, browser games, youtube, all are affected equally badly.

I've swapped mice with Mongrel, who has a fancy high-twitch gaming mouse and an advanced driver. This had zero effect on the problem, the new mouse had the same issues. Tried plugging various mice from my parts drawer in to various USB ports on different parts of the case, and using the latest basic Microsoft generic driver, all had the SAME issue.

--It's not the mouse - these work fine when returned to their natural habitat
--It's not the driver - I used the driver that came with the mouse and that made no difference over the basic Microsoft driver
--It's not the USB port - I tried USB ports in various places (front of case, back of case, top of external drive, expansion card) and none behaved as if it were a single electrical fault or culprit.
--Other devices plugged into the usb ports work as intended and aren't seeing strange electrical faults or signal dropout
--It's not the programs I'm using. It does not seem to care whether I have photoshop, youtube, emulator, etc. open

Sure would like to know what's causing it.

System info: Intel Core i7 920 @ 2.67 GHz
ASUS P6T SE mobo
12 GB DDR3
win 7 pro 64-bit
8 USB ports, 6 in rear (one dedicated for keyboard), 2 in front
AMD Radeon Sapphire 5770 gpu that has a rattley fan; one of two identical. the other gpu was crosslinked to this but it had the same fan failure thing going so I removed it years ago. Long before this mouse shit started happening.
750w psu

One other pointer device: a Wacom tablet that runs on its own proprietary driver and has never had a conflict with the mouse; Currently not mounted, because Mongrel is using it for comics on his comp.

Surge protector: APC Back-UPS ES 750 (no battery backup anymore, only surge protection)

Re: Computerus

Posted: Sat May 19, 2018 4:10 pm
by Mongrel
So... issue is that Firefox renders some non-latin-alphabet characters, but not all of them (and also many of the newer emoji). So, sick of seeing hex code boxes whenever that happens, I figured, okay, just download the additional character packs or change whatever config setting to sort this out.

I thought this would be a simple problem with an easy-to-find answer and that I had just been too lazy to google it, but it turns out I can't find a damn thing! So uh, any ideas? In my about:config, my character settings are:


Any ideas?

EDIT: Several more pieces of information

1) It's not just a Firefox issue - Chrome is similarly affected (but simply displays blank boxes instead of ones with numbers within)
2) Reducing FF security settings to 1 changed nothing (for testing purposes only - there's a known issue with some character display conflicting with security settings in FF Quantum)
3) Yes, FF is configured to allow websites to set their own fonts

Could this be an issue in Windows (Win7 here) where I need to update my font library?