User avatar
Posts: 8347
Joined: Tue Jan 21, 2014 10:05 am
Location: 1611 Uranus Avenue

Re: Vita

Postby Thad » Fri Sep 22, 2017 1:19 am

I bought Dragon Quest Builders.

Because I like to own things, I bought a physical copy.

Because it was never released in America on physical media, I bought a copy from Malaysia on eBay.

Because the game won't run on firmware v3.20, I finally bit the bullet and upgraded to v3.60.

At which point I found out the game won't run on a PlayStation TV. There is some conjecture that Sony has blacklisted some games on PSTV for no technical reason but merely because it doesn't want the PSTV cannibalizing PS4 sales.

Seriously, the PlayStation TV is the most consumer-hostile device I have ever seen in my life. (I've heard about worse -- the "smart" thermostat whose vendor shut down the servers so it no longer works, the "smart" garage door opener whose vendor blacklisted one of its customers because he left a negative review, that sort of thing -- but I am not the kind of man who buys a garage door opener that connects to the Internet, so this is the most consumer-hostile device I've ever personally used.)

So I installed Henkaku. Then I installed Ant-Blacklist.

I say "I installed Anti-Blacklist", but actually first I had to read the docs and figure out that I had to download it on my computer, run an app on my PSTV to run an FTP server, and upload it. And then Filezilla kept failing to upload, so I switched to command-line FTP, and then that failed, and then I finally figured out that, contrary to the docs I was reading, the root directory on the card was not writable and I had to go into a subdirectory before I could upload.

And then I had a bunch of problems and tried some other apps, rebooted a few times, uninstalled and reinstalled the game a couple times, and eventually worked out, entirely by accident, that I had to go into Settings, then go to Henkaku Settings, and then check a box to allow unsafe operations (read: mounting system directories rw), and then run Anti-Blacklist.

Then I rebooted and now the game works!

All told it took about 75 minutes between plugging the game in and getting to run it. I say "run" and not "play" because by then it was 9:45 at night and I have work tomorrow.

You can buy a device now that'll let you use a standard memory card on the Vita; they call it an SD2Vita. I intend to get one.

Now that I've got it working, I'm pretty excited about the potential of the PSTV as a cheap, hacker-friendly console (like the PSP was, but without nearly this much fucking hassle). You can still get one on Amazon, $90 with a controller, $70 without (affiliate links).

But understand that this device fucking hates you, and your relationship with it will be adversarial. It has some very good games, many of which it will not allow you to play even when you legally purchase them. If you are the sort of person who derives more joy from forcing a device you own to run games you own that it is designed to prevent you from running -- perhaps more than you enjoy actually playing the games themselves -- then the PlayStation TV is the console for you.

Also there's an AM2R port for it. I should check that out; I can't get the version on my HTPC to recognize my damn controller.

Who is online

Users browsing this forum: No registered users and 1 guest